summaryrefslogtreecommitdiff
path: root/Biz.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz.nix')
-rw-r--r--Biz.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/Biz.nix b/Biz.nix
new file mode 100644
index 0000000..c87f91a
--- /dev/null
+++ b/Biz.nix
@@ -0,0 +1,25 @@
+# nunya
+{ bild, ... }:
+
+# This is the biz hosting service. Currently it defines a base OS similar to
+# Omni/Cloud.nix et al and starts each Biz/* thing as a systemd service. A
+# better solution might be to define each Biz/* thing as a container, and then
+# wire them together as necessary here, but I don't know how that works so I'll
+# just stick to this method for now.
+
+bild.os {
+ imports = [
+ ./Omni/Cloud/Hardware.nix
+ ./Omni/Os/Base.nix
+ ./Omni/Packages.nix
+ ./Omni/Users.nix
+ ./Biz/Storybook.nix
+ ];
+ networking.hostName = "biz";
+ networking.domain = "storybook.bensima.com";
+ time.timeZone = "America/New_York";
+ services.storybook = {
+ enable = true;
+ package = bild.run ./Biz/Storybook.py;
+ };
+}