summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index e7aaf7f..ad56549 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -112,10 +112,10 @@ rec {
installPhase = "exit 0";
} // { env = ghc; };
- env = nixpkgs.pkgs.mkShell {
+ env = let linters = with nixpkgs.pkgs; [ ormolu hlint deadnix ]; in nixpkgs.pkgs.mkShell {
name = "bizdev";
# this should just be dev tools
- buildInputs = with nixpkgs.pkgs; [
+ buildInputs = with nixpkgs.pkgs; linters ++ [
gcc
bild
ctags
@@ -131,7 +131,7 @@ rec {
];
};
- os = cfg: (nixpkgs.nixos (args: cfg)).toplevel;
+ os = cfg: (nixpkgs.nixos (_args: cfg)).toplevel;
pkgs = { inherit (nixpkgs) git; };