summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix13
1 files changed, 12 insertions, 1 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index c7c3207..1e4bcf8 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -46,7 +46,18 @@ in nixpkgs // { bild = rec {
c.packages = lib.attrsets.getAttrs (import ./Bild/Deps/C.nix) nixpkgs.pkgs;
# expose some packages for inclusion in os/image builds
- pkgs = with nixpkgs.pkgs; { inherit git; };
+ pkgs = with nixpkgs.pkgs; {
+ inherit
+ black
+ deadnix
+ git
+ hlint
+ indent
+ ormolu
+ ruff
+ shellcheck
+ ;
+ };
# this is needed to do builds without calling out to nix, remove this when I
# switch to all-nix builds