summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index 859d070..ec049d8 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -11,6 +11,9 @@ let
stdenv = nixpkgs.nixos-23_11.ccacheStdenv;
};
+ # just needed for running ollama
+ unstable = nixpkgs.nixos-unstable-small;
+
# this is the main library definitions, recursive references can be made with
# `self.thing`, like in Python objects
self = {
@@ -79,6 +82,7 @@ let
inherit bat bc cmark ctags deadnix fd figlet fzf git git-branchless
gitlint guile hlint indent jq lolcat mypy nixfmt ormolu pkg-config
ripgrep rustc tree wemux;
+ ollama = nixpkgs.nixos-unstable-small.ollama;
ruff = nixpkgs.nixos-unstable-small.ruff;
shellcheck = nixpkgs.nixos-unstable-small.shellcheck;
};
@@ -195,6 +199,7 @@ let
# build an operating system. 'cfg' is the NixOS config
os = cfg: (stable.nixos (_args: cfg)).toplevel;
+ os-unstable = cfg: (unstable.nixos (_args: cfg)).toplevel;
# build a docker image
image = stable.dockerTools.buildImage;