summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Bild/Deps.nix')
-rw-r--r--Biz/Bild/Deps.nix19
1 files changed, 13 insertions, 6 deletions
diff --git a/Biz/Bild/Deps.nix b/Biz/Bild/Deps.nix
index 46fa00f..23b096d 100644
--- a/Biz/Bild/Deps.nix
+++ b/Biz/Bild/Deps.nix
@@ -1,13 +1,9 @@
_self: super:
{
- autogen = super.callPackage ./Deps/autogen.nix { };
+ # Needs upgrading for guile 3
+ # inspekt3d = super.callPackage ./Deps/inspekt3d.nix {};
- guile = super.guile_3_0;
-
- guile-opengl = super.callPackage ./Deps/guile-opengl.nix { };
- # The libfive build is broken...
- #inspekt3d = super.callPackage ./Deps/inspekt3d.nix {};
guix = super.pkgs.stdenv.mkDerivation rec {
pname = "guix";
name = "${pname}-${version}";
@@ -35,4 +31,15 @@ _self: super:
nostr-rs-relay = super.callPackage ./Deps/nostr-rs-relay.nix { };
ollama = super.callPackage ./Deps/ollama.nix { acceleration = "cuda"; };
+
+ # https://github.com/NixOS/nixpkgs/issues/317147#issuecomment-2147343125
+ radicale = super.radicale.overrideAttrs (_old: rec {
+ version = "3.2.0";
+ src = super.fetchFromGitHub {
+ owner = "Kozea";
+ repo = "Radicale";
+ rev = "v${version}";
+ hash = "sha256-RxC8VOfdTXJZiAroDHTKjJqGWu65Z5uyb4WK1LOqubQ=";
+ };
+ });
}