summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Bild/Deps.nix')
-rw-r--r--Biz/Bild/Deps.nix55
1 files changed, 1 insertions, 54 deletions
diff --git a/Biz/Bild/Deps.nix b/Biz/Bild/Deps.nix
index 9a18c90..8f44dde 100644
--- a/Biz/Bild/Deps.nix
+++ b/Biz/Bild/Deps.nix
@@ -1,59 +1,6 @@
_self: super:
-with import ./Constants.nix;
-let
- buildCabal = sel: name: sel.callCabal2nix name super.sources.${name} { };
- buildCabalSubdir = sel:
- { name, src ? super.sources.${name}, subdir ? name }:
- sel.callCabal2nix name (src + "/${subdir}") { };
-in rec {
- haskell = super.haskell // {
- packages = super.haskell.packages // {
- "${ghcCompiler}" = super.haskell.packages."${ghcCompiler}".override
- (_old: {
- overrides = with super.pkgs.haskell.lib;
- sel: sup:
- super.overridePinnedDeps (buildCabal sel) // {
- acid-state =
- dontCheck sup.acid-state; # mac: "too many open files"
- clay = doJailbreak sup.clay;
- envy = doJailbreak sup.envy;
- fast-tags =
- sup.fast-tags.overrideAttrs (old: old // { patches = [ ]; });
- generic-data = dontCheck
- sup.generic-data; # https://github.com/Lysxia/generic-data/issues/56
- readable =
- doJailbreak sup.readable; # why is this even being built?
- servant-auth = doJailbreak (buildCabalSubdir sel {
- name = "servant-auth";
- subdir = "servant-auth/servant-auth";
- });
- servant-server = doJailbreak sup.servant-server;
- stripe-core = doJailbreak sup.stripe-core;
- stripe-haskell = dontCheck sup.stripe-haskell;
- stripe-http-client =
- doJailbreak (dontCheck sup.stripe-http-client);
- temporary = dontCheck sup.temporary;
- wai-middleware-metrics = dontCheck sup.wai-middleware-metrics;
- };
- });
- };
- };
-
- python3 = super.python3.override {
- packageOverrides = _: pysuper:
- with pysuper.pkgs.python3Packages; {
- exllama = callPackage ./Deps/exllama.nix {
- cudaPackages = super.pkgs.cudaPackages_11_7;
- };
- interegular = callPackage ./Deps/interegular.nix { };
- outlines = callPackage ./Deps/outlines.nix { };
- perscache = callPackage ./Deps/perscache.nix { };
- };
- };
-
- python3Packages = python3.pkgs;
-
+{
autogen = super.callPackage ./Deps/autogen.nix { };
guile = super.guile_3_0;