summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps/Haskell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Bild/Deps/Haskell.nix')
-rw-r--r--Biz/Bild/Deps/Haskell.nix144
1 files changed, 71 insertions, 73 deletions
diff --git a/Biz/Bild/Deps/Haskell.nix b/Biz/Bild/Deps/Haskell.nix
index 066fd86..f34bfab 100644
--- a/Biz/Bild/Deps/Haskell.nix
+++ b/Biz/Bild/Deps/Haskell.nix
@@ -1,76 +1,74 @@
-hpkgs:
+# This is the global set of Haskell packages which gets deployed to Hoogle, and
+# is available for selecting.
-# This is the global set of Haskell packages which gets deployed to Hoogle.
-
-with hpkgs;
[
- MonadRandom
- QuickCheck
- SafeSemaphore
- acid-state
- aeson
- async
- bytestring
- clay
- cmark
- cmark-lucid
- conduit
- conduit-extra
- config-ini
- containers
- directory
- docopt
- envy
- fast-logger
- filepath
- github
- hashids
- haskeline
- hmacaroons
- hostname
- http-types
- ixset
- katip
- lucid
- monad-logger
- monad-metrics
- mtl
- neat-interpolation
- network-uri
- niv
- optparse-simple
- parsec
- process
- protolude
- quickcheck-instances
- rainbow
- random
- regex-applicative
- req
- safecopy
- servant
- servant-auth
- servant-auth-server
- servant-lucid
- servant-server
- split
- stm
- stripe-haskell
- tasty
- tasty-hunit
- tasty-quickcheck
- text
- time
- transformers
- unagi-chan
- unix
- unordered-containers
- uuid
- vector
- wai
- wai-app-static
- wai-extra
- wai-middleware-metrics
- warp
- x509
+ "MonadRandom"
+ "QuickCheck"
+ "SafeSemaphore"
+ "acid-state"
+ "aeson"
+ "async"
+ "base"
+ "bytestring"
+ "clay"
+ "cmark"
+ "cmark-lucid"
+ "conduit"
+ "conduit-extra"
+ "config-ini"
+ "containers"
+ "directory"
+ "docopt"
+ "envy"
+ "fast-logger"
+ "filepath"
+ "github"
+ "hashids"
+ "haskeline"
+ "hostname"
+ "http-types"
+ "ixset"
+ "katip"
+ "lucid"
+ "monad-logger"
+ "monad-metrics"
+ "mtl"
+ "neat-interpolation"
+ "network-uri"
+ "niv"
+ "optparse-simple"
+ "parsec"
+ "process"
+ "protolude"
+ "quickcheck-instances"
+ "rainbow"
+ "random"
+ "regex-applicative"
+ "req"
+ "safecopy"
+ "servant"
+ "servant-auth"
+ "servant-auth-server"
+ "servant-lucid"
+ "servant-server"
+ "split"
+ "stm"
+ "stripe-haskell"
+ "tasty"
+ "tasty-hunit"
+ "tasty-quickcheck"
+ "text"
+ "time"
+ "transformers"
+ "unagi-chan"
+ "unix"
+ "unordered-containers"
+ "uuid"
+ "vector"
+ "wai"
+ "wai-app-static"
+ "wai-extra"
+ "wai-middleware-metrics"
+ "warp"
+ "x509"
]