summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps/autogen.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Bild/Deps/autogen.nix')
-rw-r--r--Biz/Bild/Deps/autogen.nix61
1 files changed, 32 insertions, 29 deletions
diff --git a/Biz/Bild/Deps/autogen.nix b/Biz/Bild/Deps/autogen.nix
index b7b034d..fc95b14 100644
--- a/Biz/Bild/Deps/autogen.nix
+++ b/Biz/Bild/Deps/autogen.nix
@@ -1,5 +1,6 @@
# From: https://github.com/NixOS/nixpkgs/pull/139361
-{ lib, stdenv, buildPackages, fetchurl, fetchpatch, autoreconfHook, which, pkg-config, perl, guile, libxml2 }:
+{ lib, stdenv, buildPackages, fetchurl, fetchpatch, autoreconfHook, which
+, pkg-config, perl, guile, libxml2 }:
stdenv.mkDerivation rec {
pname = "autogen";
@@ -11,11 +12,12 @@ stdenv.mkDerivation rec {
};
patches = let
- dp = { ver ? "1%255.18.16-4", pname, name ? (pname + ".diff"), sha256 }: fetchurl {
- url = "https://salsa.debian.org/debian/autogen/-/raw/debian/${ver}"
+ dp = { ver ? "1%255.18.16-4", pname, name ? (pname + ".diff"), sha256 }:
+ fetchurl {
+ url = "https://salsa.debian.org/debian/autogen/-/raw/debian/${ver}"
+ "/debian/patches/${pname}.diff?inline=false";
- inherit name sha256;
- };
+ inherit name sha256;
+ };
in [
(dp {
pname = "20_no_Werror";
@@ -33,7 +35,8 @@ stdenv.mkDerivation rec {
# patch meanwhile.
(fetchpatch {
name = "guile-3.patch";
- url = "https://gitweb.gentoo.org/repo/gentoo.git/plain/sys-devel/autogen/files/autogen-5.18.16-guile-3.patch?id=43bcc61c56a5a7de0eaf806efec7d8c0e4c01ae7";
+ url =
+ "https://gitweb.gentoo.org/repo/gentoo.git/plain/sys-devel/autogen/files/autogen-5.18.16-guile-3.patch?id=43bcc61c56a5a7de0eaf806efec7d8c0e4c01ae7";
sha256 = "18d7y1f6164dm1wlh7rzbacfygiwrmbc35a7qqsbdawpkhydm5lr";
})
];
@@ -41,37 +44,37 @@ stdenv.mkDerivation rec {
outputs = [ "bin" "dev" "lib" "out" "man" "info" ];
nativeBuildInputs = [
- which pkg-config perl autoreconfHook/*patches applied*/
+ which
+ pkg-config
+ perl
+ autoreconfHook # patches applied
] ++ lib.optionals (stdenv.hostPlatform != stdenv.buildPlatform) [
# autogen needs a build autogen when cross-compiling
- buildPackages.buildPackages.autogen buildPackages.texinfo
- ];
- buildInputs = [
- guile libxml2
+ buildPackages.buildPackages.autogen
+ buildPackages.texinfo
];
+ buildInputs = [ guile libxml2 ];
preConfigure = ''
export MAN_PAGE_DATE=$(date '+%Y-%m-%d' -d "@$SOURCE_DATE_EPOCH")
'';
- configureFlags =
- [
- # Make sure to use a static value for the timeout. If we do not set a value
- # here autogen will select one based on the execution time of the configure
- # phase which is not really reproducible.
- #
- # If you are curious about the number 78, it has been cargo-culted from
- # Debian: https://salsa.debian.org/debian/autogen/-/blob/master/debian/rules#L21
- "--enable-timeout=78"
- ]
- ++ (lib.optionals (stdenv.hostPlatform != stdenv.buildPlatform) [
- "--with-libxml2=${libxml2.dev}"
- "--with-libxml2-cflags=-I${libxml2.dev}/include/libxml2"
- # the configure check for regcomp wants to run a host program
- "libopts_cv_with_libregex=yes"
- #"MAKEINFO=${buildPackages.texinfo}/bin/makeinfo"
- ])
- # See: https://sourceforge.net/p/autogen/bugs/187/
+ configureFlags = [
+ # Make sure to use a static value for the timeout. If we do not set a value
+ # here autogen will select one based on the execution time of the configure
+ # phase which is not really reproducible.
+ #
+ # If you are curious about the number 78, it has been cargo-culted from
+ # Debian: https://salsa.debian.org/debian/autogen/-/blob/master/debian/rules#L21
+ "--enable-timeout=78"
+ ] ++ (lib.optionals (stdenv.hostPlatform != stdenv.buildPlatform) [
+ "--with-libxml2=${libxml2.dev}"
+ "--with-libxml2-cflags=-I${libxml2.dev}/include/libxml2"
+ # the configure check for regcomp wants to run a host program
+ "libopts_cv_with_libregex=yes"
+ #"MAKEINFO=${buildPackages.texinfo}/bin/makeinfo"
+ ])
+ # See: https://sourceforge.net/p/autogen/bugs/187/
++ lib.optionals stdenv.isDarwin [ "ac_cv_func_utimensat=no" ];
#doCheck = true; # not reliable