summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps/exllama.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Bild/Deps/exllama.nix')
-rw-r--r--Biz/Bild/Deps/exllama.nix20
1 files changed, 5 insertions, 15 deletions
diff --git a/Biz/Bild/Deps/exllama.nix b/Biz/Bild/Deps/exllama.nix
index 1f7e529..51a05e9 100644
--- a/Biz/Bild/Deps/exllama.nix
+++ b/Biz/Bild/Deps/exllama.nix
@@ -1,14 +1,6 @@
-{ lib
-, sources
-, buildPythonPackage
-, pythonOlder
+{ lib, sources, buildPythonPackage, pythonOlder
, torch # tested on 2.0.1 and 2.1.0 (nightly) with cu118
-, safetensors
-, sentencepiece
-, ninja
-, cudaPackages
-, addOpenGLRunpath
-, which
+, safetensors, sentencepiece, ninja, cudaPackages, addOpenGLRunpath, which
, gcc11 # cuda 11.7 requires g++ <12
}:
@@ -36,12 +28,10 @@ buildPythonPackage rec {
cudaPackages.cuda_cudart
];
- propagatedBuildInputs = [
- torch safetensors sentencepiece ninja
- cudaPackages.cudatoolkit
- ];
+ propagatedBuildInputs =
+ [ torch safetensors sentencepiece ninja cudaPackages.cudatoolkit ];
- doCheck = false; # no tests currently
+ doCheck = false; # no tests currently
pythonImportsCheck = [
"exllama"
"exllama.cuda_ext"