summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps/llm-ollama.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Bild/Deps/llm-ollama.nix')
-rw-r--r--Biz/Bild/Deps/llm-ollama.nix40
1 files changed, 0 insertions, 40 deletions
diff --git a/Biz/Bild/Deps/llm-ollama.nix b/Biz/Bild/Deps/llm-ollama.nix
deleted file mode 100644
index e2b6a66..0000000
--- a/Biz/Bild/Deps/llm-ollama.nix
+++ /dev/null
@@ -1,40 +0,0 @@
-{ buildPythonPackage, fetchFromGitHub, lib, llm, ollama, pytestCheckHook
-, setuptools, pythonOlder, }:
-buildPythonPackage rec {
- pname = "llm-ollama";
- version = "0.3.0";
- pyproject = true;
-
- disabled = pythonOlder "3.8";
-
- src = fetchFromGitHub {
- owner = "taketwo";
- repo = pname;
- rev = "refs/tags/${version}";
- hash = "sha256-Ar0Ux8BNGY0i764CEk7+48J6jnndlRIIMPZ9tFpXiy4=";
- };
-
- nativeBuildInputs = [ setuptools ];
-
- buildInputs = [ llm ollama ];
-
- propagatedBuildInputs = [ ollama ];
-
- disabledTests = [
- # wants to mkdir in the /homeless-shelter
- "test_registered_models"
- ];
-
- nativeCheckInputs = [ pytestCheckHook ];
-
- pythonImportsCheck = [ "llm_ollama" ];
-
- meta = with lib; {
- homepage = "https://github.com/taketwo/llm-ollama";
- description =
- "LLM plugin providing access to local Ollama models usting HTTP API";
- changelog = "https://github.com/taketwo/llm-ollama/releases/tag/${version}";
- license = licenses.asl20;
- maintainers = with maintainers; [ bsima ];
- };
-}