summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps/perscache.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Bild/Deps/perscache.nix')
-rw-r--r--Biz/Bild/Deps/perscache.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/Biz/Bild/Deps/perscache.nix b/Biz/Bild/Deps/perscache.nix
new file mode 100644
index 0000000..d757e1a
--- /dev/null
+++ b/Biz/Bild/Deps/perscache.nix
@@ -0,0 +1,39 @@
+{ lib
+, sources
+, buildPythonPackage
+, beartype
+, cloudpickle
+, icontract
+, pbr
+}:
+
+buildPythonPackage rec {
+ pname = "perscache";
+ version = sources.perscache.rev;
+
+ src = sources.perscache;
+
+ propagatedBuildInputs = [
+ beartype
+ cloudpickle
+ icontract
+ pbr
+ ];
+ PBR_VERSION = version;
+
+ doCheck = false; # no tests currently
+ pythonImportsCheck = [
+ "perscache"
+ ];
+
+ meta = with lib; {
+ description = ''
+ An easy to use decorator for persistent memoization: like
+ `functools.lrucache`, but results can be saved in any format to any
+ storage.
+ '';
+ homepage = "https://github.com/leshchenko1979/perscache";
+ license = licenses.mit;
+ maintainers = with maintainers; [ bsima ];
+ };
+}