summaryrefslogtreecommitdiff
path: root/Biz/Bild/Python.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Bild/Python.nix')
-rw-r--r--Biz/Bild/Python.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/Biz/Bild/Python.nix b/Biz/Bild/Python.nix
new file mode 100644
index 0000000..51f35f1
--- /dev/null
+++ b/Biz/Bild/Python.nix
@@ -0,0 +1,23 @@
+_self: super: {
+ python3 = super.python3.override {
+ packageOverrides = _pyself: pysuper:
+ with pysuper.pkgs.python3Packages;
+ let dontCheck = p: p.overridePythonAttrs (_: { doCheck = false; });
+ in {
+ exllama = callPackage ./Deps/exllama.nix {
+ cudaPackages = super.pkgs.cudaPackages_11_7;
+ };
+ exllamav2 = callPackage ./Deps/exllamav2.nix {
+ cudaPackages = super.pkgs.cudaPackages_11_7;
+ };
+ interegular = callPackage ./Deps/interegular.nix { };
+ mypy = dontCheck pysuper.mypy;
+ outlines = callPackage ./Deps/outlines.nix { };
+ perscache = callPackage ./Deps/perscache.nix { };
+ safetensors = super.nixos-23_11.python310Packages.safetensors.override {
+ buildPythonPackage = pysuper.pkgs.python3Packages.buildPythonPackage;
+ };
+ tokenizers = dontCheck pysuper.tokenizers;
+ };
+ };
+}