summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Cgit.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Cloud/Cgit.nix')
-rw-r--r--Biz/Cloud/Cgit.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/Biz/Cloud/Cgit.nix b/Biz/Cloud/Cgit.nix
index 78eda7b..0b3a71b 100644
--- a/Biz/Cloud/Cgit.nix
+++ b/Biz/Cloud/Cgit.nix
@@ -36,6 +36,14 @@ in
Location to serve cgit on.
'';
};
+
+ allowCrawlers = mkOption {
+ default = true;
+ type = types.bool;
+ description = ''
+ Allow search engines to crawl and index this site.
+ '';
+ };
};
# Remove the global options for serialization into cgitrc
@@ -108,6 +116,13 @@ in
fastcgi_split_path_info ^(${location}/)(/?.+)$;
fastcgi_param PATH_INFO $fastcgi_path_info;
''
+ ) + (
+ if !cfg.allowCrawlers
+ then
+ ''
+ add_header X-Robots-Tag "noindex, follow" always;
+ ''
+ else ""
);
};
};