summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Chat.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Cloud/Chat.nix')
-rw-r--r--Biz/Cloud/Chat.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/Biz/Cloud/Chat.nix b/Biz/Cloud/Chat.nix
index bc97973..6f8ac3a 100644
--- a/Biz/Cloud/Chat.nix
+++ b/Biz/Cloud/Chat.nix
@@ -2,6 +2,9 @@
#
# a homeserver for matrix.org.
#
+# this uses the config.networking.domain as the ACME host. be sure to add the
+# fqdn and element subdomains to security.acme.certs.<name>.extraDomainNames
+#
# - nixos manual: https://nixos.org/nixos/manual/index.html#module-services-matrix
#
# to create new users:
@@ -72,8 +75,8 @@ in {
};
# reverse proxy for matrix client-server and server-server communication
"${fqdn}" = {
- enableACME = true;
forceSSL = true;
+ useACMEHost = config.networking.domain;
locations."/".extraConfig = ''
return 404;
'';
@@ -90,11 +93,8 @@ in {
# https://github.com/vector-im/element-web#important-security-note
#
services.nginx.virtualHosts."${element}" = {
- enableACME = true;
+ useACMEHost = config.networking.domain;
forceSSL = true;
- serverAliases = [
- "chat.${config.networking.domain}"
- ];
root = pkgs.element-web;
};
}