summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Cloud/Git.nix')
-rw-r--r--Biz/Cloud/Git.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/Biz/Cloud/Git.nix b/Biz/Cloud/Git.nix
index eb61a10..d1cdf9f 100644
--- a/Biz/Cloud/Git.nix
+++ b/Biz/Cloud/Git.nix
@@ -1,6 +1,7 @@
{ pkgs, lib, config, ... }:
let
+ inherit (config.networking) domain;
root = "/var/git";
in {
services = {
@@ -31,6 +32,28 @@ in {
user = "gitDaemon";
group = "gitDaemon";
};
+ nginx.virtualHosts.${domain}.cgit = {
+ enable = true;
+ location = "/git";
+ virtual-root = "/git";
+ css = "/git/cgit.css";
+ logo = "/git/cgit.png";
+ root-title = "ben's git repos";
+ root-desc = "building";
+ enable-git-config = 1;
+ clone-url = lib.strings.concatStringsSep " " [
+ "https://$HTTP_HOST/git/$CGIT_REPO_URL"
+ "git://$HTTP_HOST/$CGIT_REPO_URL"
+ "git@$HTTP_HOST:$CGIT_REPO_URL"
+ ];
+ include = [
+ # these depend on order, scan-path must come last
+ (builtins.toFile "cgitrc" ''
+ strict-export=git-daemon-export-ok
+ scan-path=${root}/repositories
+ '')
+ ];
+ };
};
# need to specify that these users can access git files by being part of the
# git group