summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Web.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Cloud/Web.nix')
-rw-r--r--Biz/Cloud/Web.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/Biz/Cloud/Web.nix b/Biz/Cloud/Web.nix
index 913bded..532c843 100644
--- a/Biz/Cloud/Web.nix
+++ b/Biz/Cloud/Web.nix
@@ -39,6 +39,33 @@ in
radicale = {
enable = true;
+ rights = {
+ # Allow reading root collection for authenticated users
+ root = {
+ user = ".+";
+ collection = "";
+ permissions = "R";
+ };
+ # Allow reading and writing principal collection (same as username)
+ principal = {
+ user = ".+";
+ collection = "{user}";
+ permissions = "RW";
+ };
+ # Allow reading and writing calendars and address books that are direct
+ # children of the principal collection
+ calendars = {
+ user = ".+";
+ collection = "{user}/[^/]+";
+ permissions = "rw";
+ };
+ # Allow any authenticated user to modify the public collection
+ public = {
+ user = ".*";
+ collection = "public/.*";
+ permissions = "rw";
+ };
+ };
settings = {
server = {
hosts = [
@@ -53,6 +80,7 @@ in
};
};
};
+
gmnisrv = {
enable = false;
listen = "0.0.0.0:${toString ports.gemini} [::]:${toString ports.gemini}";