summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Web.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Cloud/Web.nix')
-rw-r--r--Biz/Cloud/Web.nix25
1 files changed, 3 insertions, 22 deletions
diff --git a/Biz/Cloud/Web.nix b/Biz/Cloud/Web.nix
index 08e2267..fbe4e03 100644
--- a/Biz/Cloud/Web.nix
+++ b/Biz/Cloud/Web.nix
@@ -66,6 +66,9 @@ in
forceSSL = true;
enableACME = true;
locations = {
+ # the nginx/cgit module puts a '/' at the end of 'location', so we need to
+ # redirect '/git' to '/git/'
+ "/git".return = "301 https://$host/git/";
"/" = {
root = "/var/web/simatime.com";
extraConfig = ''
@@ -81,28 +84,6 @@ in
'';
};
};
- cgit = {
- enable = true;
- location = "/git";
- virtual-root = "/git";
- css = "/git/cgit.css";
- logo = "/git/cgit.png";
- root-title = "ben's git repos";
- root-desc = "building";
- enable-git-config = 1;
- clone-url = lib.strings.concatStringsSep " " [
- "https://$HTTP_HOST/git/$CGIT_REPO_URL"
- "git://$HTTP_HOST/$CGIT_REPO_URL"
- "git@$HTTP_HOST:$CGIT_REPO_URL"
- ];
- include = [
- # these depend on order, scan-path must come last
- (builtins.toFile "cgitrc" ''
- strict-export=git-daemon-export-ok
- scan-path=/var/git/repositories
- '')
- ];
- };
};
"bsima.me" = {