summaryrefslogtreecommitdiff
path: root/Biz/Dev/Configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Dev/Configuration.nix')
-rw-r--r--Biz/Dev/Configuration.nix13
1 files changed, 10 insertions, 3 deletions
diff --git a/Biz/Dev/Configuration.nix b/Biz/Dev/Configuration.nix
index b316b16..7fa0e37 100644
--- a/Biz/Dev/Configuration.nix
+++ b/Biz/Dev/Configuration.nix
@@ -223,15 +223,22 @@ in {
nix = {
- # 1 job * 2 cores = 2 maximum cores used at any one time
- maxJobs = 1;
- buildCores = 1;
+ autoOptimiseStore = true;
+ buildCores = 0; # use all available cores
# Since this is the dev machine, we can turn these on at the expense
# of extra disk space.
extraOptions = ''
keep-outputs = true
keep-derivations = true
'';
+ # 1 job * 2 cores = 2 maximum cores used at any one time
+ maxJobs = 1;
+ sshServe = {
+ enable = true;
+ keys = [
+ (builtins.readFile ../Keys/Ben.pub)
+ ];
+ };
trustedUsers = [ "root" "ben" ];
};