summaryrefslogtreecommitdiff
path: root/Biz/Dev/Configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Dev/Configuration.nix')
-rw-r--r--Biz/Dev/Configuration.nix28
1 files changed, 15 insertions, 13 deletions
diff --git a/Biz/Dev/Configuration.nix b/Biz/Dev/Configuration.nix
index abdbfab..8e316ed 100644
--- a/Biz/Dev/Configuration.nix
+++ b/Biz/Dev/Configuration.nix
@@ -22,7 +22,7 @@ in {
pkgs.k3s
pkgs.wemux
pkgs.tmux
- pkgs.wireguard
+ pkgs.wireguard-tools
];
nixpkgs = {
@@ -77,11 +77,11 @@ in {
services.tor.enable = true;
services.tor.client.enable = true;
services.tor.relay.role = "bridge";
- services.tor.relay.port = ports.tor;
- services.tor.relay.nickname = "ydeee3q1cjo83tsuqcz";
- services.tor.relay.accountingMax = "10 GBytes";
- services.tor.relay.accountingStart = "month 1 1:00";
- services.tor.relay.contactInfo = "ContactInfo pgp:66A6AD150399D970DCA4C4E6C8218B7D0BFDECCD ciissversion:2";
+ services.tor.settings.ORPort = ports.tor;
+ services.tor.settings.Nickname = "ydeee3q1cjo83tsuqcz";
+ services.tor.settings.AccountingMax = "10 GBytes";
+ services.tor.settings.AccountingStart = "month 1 1:00";
+ services.tor.settings.ContactInfo = "ContactInfo pgp:66A6AD150399D970DCA4C4E6C8218B7D0BFDECCD ciissversion:2";
services.bitcoind.mainnet.enable = true;
services.bitcoind.mainnet.dataDir = "/mnt/campbell/bitcoind-mainnet/data";
@@ -135,6 +135,8 @@ in {
services.jupyter.enable = true;
services.jupyter.port = ports.jupyter;
services.jupyter.ip = "*";
+ users.users.jupyter.group = "jupyter";
+ users.groups.jupyter = {};
services.jupyter.password = "'argon2:$argon2id$v=19$m=10240,t=10,p=8$nvQhgk+htbIYi961YYAf1w$ekpwiTT5L4+OAods0K7EDw'";
services.jupyter.kernels.python3 = let
env = (pkgs.python3.withPackages (p: with p; [
@@ -161,9 +163,9 @@ in {
services.jellyfin.group = "jellyfin";
services.minidlna.enable = true;
- services.minidlna.announceInterval = 60;
- services.minidlna.friendlyName = "Sima Media";
- services.minidlna.mediaDirs = [
+ services.minidlna.settings.notify_interval = 60;
+ services.minidlna.settings.friendly_name = "Sima Media";
+ services.minidlna.settings.media_dir = [
"V,/mnt/campbell/ben/youtube"
"A,/mnt/campbell/ben/music"
"V,/mnt/campbell/ben/torrents/done"
@@ -178,8 +180,8 @@ in {
documentation.man.enable = true;
documentation.nixos.enable = true;
- nix.autoOptimiseStore = true;
- nix.buildCores = 0; # use all available cores
+ nix.settings.auto-optimise-store = true;
+ nix.settings.cores = 0; # use all available cores
# Since this is the dev machine, we can turn these on at the expense
# of extra disk space.
nix.extraOptions = ''
@@ -187,14 +189,14 @@ in {
keep-derivations = true
'';
# 1 job * 2 cores = 2 maximum cores used at any one time
- nix.maxJobs = 1;
+ nix.settings.max-jobs = 1;
nix.sshServe.enable = true;
nix.sshServe.keys = lib.trivial.pipe ../Keys/Ben.pub [
builtins.readFile
(lib.strings.splitString "\n")
(lib.filter (s: s != ""))
];
- nix.trustedUsers = [ "root" "ben" ];
+ nix.settings.trusted-users = [ "root" "ben" ];
# This value determines the NixOS release with which your system is to be
# compatible, in order to avoid breaking some software such as database