summaryrefslogtreecommitdiff
path: root/Biz/Dev/Guix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Dev/Guix.nix')
-rw-r--r--Biz/Dev/Guix.nix43
1 files changed, 0 insertions, 43 deletions
diff --git a/Biz/Dev/Guix.nix b/Biz/Dev/Guix.nix
deleted file mode 100644
index 0b261fb..0000000
--- a/Biz/Dev/Guix.nix
+++ /dev/null
@@ -1,43 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-
-let
-
- cfg = config.services.guix;
-
-in {
-
- options.services.guix = {
- enable = mkEnableOption "GNU Guix package manager";
- };
-
- config = mkIf cfg.enable {
- systemd.services.guix-daemon = {
- description = "Build daemon for GNU Guix";
-
- wantedBy = [ "multi-user.target" ];
-
- serviceConfig = {
- Restart = "always";
- ExecStart =
- "${pkgs.guix}/bin/guix-daemon --build-users-group=guixbuild";
- Environment = null;
- RemainAfterExit = "yes";
- StandardOutput = "syslog";
- StandardError = "syslog";
- TaskMax = "8192";
- };
- };
- users = {
- extraUsers = lib.attrs.genAttrs (lib.lists.range 1 10) (n: {
- name = "guixbuilder${n}";
- isSystemUser = true;
- extraGroups = [ "guixbuild" ];
- group = "guixbuild";
- description = "Guix build user ${n}";
- });
- extraGroups = { "guixbuild" = { }; };
- };
- };
-}