summaryrefslogtreecommitdiff
path: root/Biz/Dev/Networking.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Dev/Networking.nix')
-rw-r--r--Biz/Dev/Networking.nix22
1 files changed, 5 insertions, 17 deletions
diff --git a/Biz/Dev/Networking.nix b/Biz/Dev/Networking.nix
index 1a28b56..c89add7 100644
--- a/Biz/Dev/Networking.nix
+++ b/Biz/Dev/Networking.nix
@@ -1,14 +1,11 @@
{ ... }:
-let
- ports = import ../Cloud/Ports.nix;
+let ports = import ../Cloud/Ports.nix;
in {
networking = {
nameservers = [ "1.1.1.1" ];
hostName = "lithium";
- hosts = {
- "::1" = [ "localhost" "ipv6-localhost" "ipv6-loopback" ];
- };
+ hosts = { "::1" = [ "localhost" "ipv6-localhost" "ipv6-loopback" ]; };
firewall = {
allowedTCPPorts = [
@@ -32,18 +29,9 @@ in {
ports.stableDiffusion
ports.tor
];
- allowedTCPPortRanges = [
- ports.torrents
- ports.httpdev
- ];
- allowedUDPPorts = [
- ports.dns
- ports.et
- ports.murmur
- ];
- allowedUDPPortRanges = [
- ports.torrents
- ];
+ allowedTCPPortRanges = [ ports.torrents ports.httpdev ];
+ allowedUDPPorts = [ ports.dns ports.et ports.murmur ];
+ allowedUDPPortRanges = [ ports.torrents ];
};
# The global useDHCP flag is deprecated, therefore explicitly set to false here.