summaryrefslogtreecommitdiff
path: root/Biz/OsBase.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/OsBase.nix')
-rw-r--r--Biz/OsBase.nix18
1 files changed, 12 insertions, 6 deletions
diff --git a/Biz/OsBase.nix b/Biz/OsBase.nix
index 3b59f11..50899d2 100644
--- a/Biz/OsBase.nix
+++ b/Biz/OsBase.nix
@@ -1,14 +1,20 @@
-{pkgs, ...}:
-let
- ports = import ./Cloud/Ports.nix;
+{ pkgs, ... }:
+let ports = import ./Cloud/Ports.nix;
in {
boot.tmp.cleanOnBoot = true;
fonts.fonts = with pkgs; [
- google-fonts mononoki source-code-pro fantasque-sans-mono hack-font
- fira fira-code fira-code-symbols
+ google-fonts
+ mononoki
+ source-code-pro
+ fantasque-sans-mono
+ hack-font
+ fira
+ fira-code
+ fira-code-symbols
];
networking.firewall.allowPing = true;
- nix.settings.substituters = [ "https://cache.nixos.org" ]; # "ssh://dev.simatime.com" ];
+ nix.settings.substituters =
+ [ "https://cache.nixos.org" ]; # "ssh://dev.simatime.com" ];
nix.gc.automatic = true;
nix.gc.dates = "Sunday 02:15";
nix.optimise.automatic = true;