summaryrefslogtreecommitdiff
path: root/Biz/Que/Host.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Que/Host.nix')
-rw-r--r--Biz/Que/Host.nix14
1 files changed, 4 insertions, 10 deletions
diff --git a/Biz/Que/Host.nix b/Biz/Que/Host.nix
index 84bd9cc..b6b533e 100644
--- a/Biz/Que/Host.nix
+++ b/Biz/Que/Host.nix
@@ -1,13 +1,7 @@
-{ options
-, lib
-, config
-, ...
-}:
+{ options, lib, config, ... }:
-let
- cfg = config.services.que-server;
-in
-{
+let cfg = config.services.que-server;
+in {
options.services.que-server = {
enable = lib.mkEnableOption "Enable the que-server service";
port = lib.mkOption {
@@ -34,7 +28,7 @@ in
Que server
'';
serviceConfig = {
- Environment = ["QUE_PORT=${toString cfg.port}"];
+ Environment = [ "QUE_PORT=${toString cfg.port}" ];
EnvironmentFile = "/run/que/env";
KillSignal = "INT";
Type = "simple";