summaryrefslogtreecommitdiff
path: root/Biz/users.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/users.nix')
-rw-r--r--Biz/users.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/Biz/users.nix b/Biz/users.nix
new file mode 100644
index 0000000..b52043e
--- /dev/null
+++ b/Biz/users.nix
@@ -0,0 +1,39 @@
+{ config, ... }:
+
+{
+ users.motd = ''
+
+ welcome to the simatime network!
+ your host is '${config.networking.hostName}'
+
+ '';
+ users.mutableUsers = false;
+ users.users = { #
+ # bots
+ #
+ deploy = {
+ isNormalUser = true;
+ home = "/home/deploy";
+ openssh.authorizedKeys.keyFiles = [ ./keys/deploy.pub ];
+ extraGroups = [ "wheel" ];
+ };
+ #
+ # humans
+ #
+ root.openssh.authorizedKeys.keyFiles = [ ./keys/ben.pub ];
+ ben = {
+ description = "Ben Sima";
+ isNormalUser = true;
+ home = "/home/ben";
+ openssh.authorizedKeys.keyFiles = [ ./keys/ben.pub ];
+ extraGroups = [ "wheel" "networkmanager" "docker" ];
+ };
+ nick = {
+ description = "Nick Sima";
+ isNormalUser = true;
+ home = "/home/nick";
+ openssh.authorizedKeys.keyFiles = [ ./keys/nick.pub ];
+ extraGroups = [ "docker" ];
+ };
+ };
+}