summaryrefslogtreecommitdiff
path: root/Com/MusicMeetsComics/Service.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Com/MusicMeetsComics/Service.nix')
-rw-r--r--Com/MusicMeetsComics/Service.nix76
1 files changed, 0 insertions, 76 deletions
diff --git a/Com/MusicMeetsComics/Service.nix b/Com/MusicMeetsComics/Service.nix
deleted file mode 100644
index f0f4227..0000000
--- a/Com/MusicMeetsComics/Service.nix
+++ /dev/null
@@ -1,76 +0,0 @@
-{ options
-, lib
-, config
-, pkgs
-, modulesPath
-}:
-
-let
- cfg = config.services.herocomics;
-in
-{
- options.services.herocomics = {
- enable = lib.mkEnableOption "Enable the herocomics service";
- port = lib.mkOption {
- type = lib.types.int;
- default = 3000;
- description = ''
- The port on which herocomics-server will listen for incoming HTTP traffic.
- '';
- };
- server = lib.mkOption {
- type = lib.types.package;
- description = "herocomics-server package to use";
- };
- client = lib.mkOption {
- type = lib.types.package;
- description = "herocomics-client package to use";
- };
- domain = lib.mkOption {
- type = lib.types.str;
- default = "herocomics.app";
- description = ''
- Domain on which to bind herocomics-server. This is passed
- to services.nginx.virtualHosts.<name> directly.
- '';
- };
- };
- config = lib.mkIf cfg.enable {
- systemd.services.herocomics = {
- path = [ cfg.server ];
- wantedBy = [ "multi-user.target" ];
- script = ''
- ${cfg.server}/bin/mmc
- '';
- description = ''
- Hero Comics app server
- '';
- serviceConfig = {
- KillSignal = "INT";
- Environment = [
- "HERO_CLIENT=${cfg.client}/static"
- "HERO_PORT=${toString cfg.port}"
- ];
- Type = "simple";
- Restart = "on-abort";
- RestartSec = "1";
- };
- };
- services.nginx = {
- enable = cfg.enable;
- recommendedGzipSettings = true;
- recommendedOptimisation = true;
- recommendedProxySettings = true;
- recommendedTlsSettings = true;
- virtualHosts = {
- "${cfg.domain}" = {
- forceSSL = true;
- enableACME = true;
- locations."/" = {
- proxyPass = "http://localhost:${toString cfg.port}";
- };
- };
- };
- };
- };
-}