summaryrefslogtreecommitdiff
path: root/Com/Simatime/Prod/networking.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Com/Simatime/Prod/networking.nix')
-rwxr-xr-xCom/Simatime/Prod/networking.nix15
1 files changed, 9 insertions, 6 deletions
diff --git a/Com/Simatime/Prod/networking.nix b/Com/Simatime/Prod/networking.nix
index 79fbe27..6180dde 100755
--- a/Com/Simatime/Prod/networking.nix
+++ b/Com/Simatime/Prod/networking.nix
@@ -6,23 +6,26 @@
"67.207.67.2"
"67.207.67.3"
];
- defaultGateway = "157.245.160.1";
- defaultGateway6 = "";
+ defaultGateway = "157.245.224.1";
+ defaultGateway6 = "2604:a880:2:d1::1";
dhcpcd.enable = false;
usePredictableInterfaceNames = lib.mkForce true;
interfaces = {
eth0 = {
ipv4.addresses = [
- { address="157.245.167.217"; prefixLength=20; }
- { address="10.46.0.8"; prefixLength=16; }
+ { address="157.245.236.44"; prefixLength=20; }
+ { address="10.46.0.5"; prefixLength=16; }
];
ipv6.addresses = [
- { address="fe80::242a:8bff:feb7:6afb"; prefixLength=64; }
+ { address="2604:a880:2:d1::a2:5001"; prefixLength=64; }
+ { address="fe80::7892:a5ff:fec6:dbc3"; prefixLength=64; }
];
+ ipv4.routes = [ { address = "157.245.224.1"; prefixLength = 32; } ];
+ ipv6.routes = [ { address = "2604:a880:2:d1::1"; prefixLength = 32; } ];
};
};
};
services.udev.extraRules = ''
- ATTR{address}=="26:2a:8b:b7:6a:fb", NAME="eth0"
+ ATTR{address}=="7a:92:a5:c6:db:c3", NAME="eth0"
'';
}