summaryrefslogtreecommitdiff
path: root/Com/Simatime/Serval/networking.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Com/Simatime/Serval/networking.nix')
-rwxr-xr-xCom/Simatime/Serval/networking.nix28
1 files changed, 0 insertions, 28 deletions
diff --git a/Com/Simatime/Serval/networking.nix b/Com/Simatime/Serval/networking.nix
deleted file mode 100755
index 79fbe27..0000000
--- a/Com/Simatime/Serval/networking.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-{ lib, ... }: {
- # This file was populated at runtime with the networking
- # details gathered from the active system.
- networking = {
- nameservers = [
- "67.207.67.2"
- "67.207.67.3"
- ];
- defaultGateway = "157.245.160.1";
- defaultGateway6 = "";
- dhcpcd.enable = false;
- usePredictableInterfaceNames = lib.mkForce true;
- interfaces = {
- eth0 = {
- ipv4.addresses = [
- { address="157.245.167.217"; prefixLength=20; }
- { address="10.46.0.8"; prefixLength=16; }
- ];
- ipv6.addresses = [
- { address="fe80::242a:8bff:feb7:6afb"; prefixLength=64; }
- ];
- };
- };
- };
- services.udev.extraRules = ''
- ATTR{address}=="26:2a:8b:b7:6a:fb", NAME="eth0"
- '';
-}