summaryrefslogtreecommitdiff
path: root/Com/Simatime/users.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Com/Simatime/users.nix')
-rw-r--r--Com/Simatime/users.nix61
1 files changed, 35 insertions, 26 deletions
diff --git a/Com/Simatime/users.nix b/Com/Simatime/users.nix
index c951c8e..ea2ef74 100644
--- a/Com/Simatime/users.nix
+++ b/Com/Simatime/users.nix
@@ -1,28 +1,37 @@
-{ #
- # bots
- #
- deploy = {
- isNormalUser = true;
- home = "/home/deploy";
- openssh.authorizedKeys.keyFiles = [ ./keys/deploy.pub ];
- extraGroups = [ "wheel" ];
- };
- #
- # humans
- #
- root.openssh.authorizedKeys.keyFiles = [ ./keys/ben.pub ];
- ben = {
- description = "Ben Sima";
- isNormalUser = true;
- home = "/home/ben";
- openssh.authorizedKeys.keyFiles = [ ./keys/ben.pub ];
- extraGroups = [ "wheel" "networkmanager" "docker" ];
- };
- nick = {
- description = "Nick Sima";
- isNormalUser = true;
- home = "/home/nick";
- openssh.authorizedKeys.keyFiles = [ ./keys/nick.pub ];
- extraGroups = [ "docker" ];
+{ config, ... }:
+
+{
+ users.motd = '''
+ welcome to the simatime network
+ ${config.networking.hostName}
+ '';
+ users.mutableUsers = false;
+ users.users = { #
+ # bots
+ #
+ deploy = {
+ isNormalUser = true;
+ home = "/home/deploy";
+ openssh.authorizedKeys.keyFiles = [ ./keys/deploy.pub ];
+ extraGroups = [ "wheel" ];
+ };
+ #
+ # humans
+ #
+ root.openssh.authorizedKeys.keyFiles = [ ./keys/ben.pub ];
+ ben = {
+ description = "Ben Sima";
+ isNormalUser = true;
+ home = "/home/ben";
+ openssh.authorizedKeys.keyFiles = [ ./keys/ben.pub ];
+ extraGroups = [ "wheel" "networkmanager" "docker" ];
+ };
+ nick = {
+ description = "Nick Sima";
+ isNormalUser = true;
+ home = "/home/nick";
+ openssh.authorizedKeys.keyFiles = [ ./keys/nick.pub ];
+ extraGroups = [ "docker" ];
+ };
};
}