summaryrefslogtreecommitdiff
path: root/Com/Simatime/users.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Com/Simatime/users.nix')
-rw-r--r--Com/Simatime/users.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/Com/Simatime/users.nix b/Com/Simatime/users.nix
new file mode 100644
index 0000000..daac9d6
--- /dev/null
+++ b/Com/Simatime/users.nix
@@ -0,0 +1,33 @@
+{ ... }:
+
+let
+ key = f: builtins.readFile (./keys/. + ("/" + f));
+in
+{
+ users = {
+ users = {
+ # bots
+ deploy = {
+ isNormalUser = true;
+ home = "/home/deploy";
+ openssh.authorizedKeys.keys = [ (key "deploy.pub") ];
+ extraGroups = [ "wheel" ];
+ };
+
+ # humans
+ root.openssh.authorizedKeys.keys = [ (key "ben.pub") ];
+ ben = {
+ isNormalUser = true;
+ home = "/home/ben";
+ openssh.authorizedKeys.keys = [ (key "ben.pub") ];
+ extraGroups = [ "wheel" "networkmanager" "docker" ];
+ };
+ nick = {
+ isNormalUser = true;
+ home = "/home/nick";
+ openssh.authorizedKeys.keys = [ (key "nick.pub") ];
+ extraGroups = [ "docker" ];
+ };
+ };
+ };
+}