summaryrefslogtreecommitdiff
path: root/Omni/Bild/Python.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Omni/Bild/Python.nix')
-rw-r--r--Omni/Bild/Python.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/Omni/Bild/Python.nix b/Omni/Bild/Python.nix
new file mode 100644
index 0000000..6e4f390
--- /dev/null
+++ b/Omni/Bild/Python.nix
@@ -0,0 +1,17 @@
+_self: super: {
+ python3 = super.python3.override {
+ packageOverrides = _pyself: pysuper:
+ with pysuper.pkgs.python3Packages;
+ let dontCheck = p: p.overridePythonAttrs (_: { doCheck = false; });
+ in {
+ interegular = callPackage ./Deps/interegular.nix { };
+ llm-ollama = callPackage ./Deps/llm-ollama.nix { };
+ llm-sentence-transformers =
+ callPackage ./Deps/llm-sentence-transformers.nix { };
+ mypy = dontCheck pysuper.mypy;
+ outlines = callPackage ./Deps/outlines.nix { };
+ perscache = callPackage ./Deps/perscache.nix { };
+ tokenizers = dontCheck pysuper.tokenizers;
+ };
+ };
+}