summaryrefslogtreecommitdiff
path: root/Omni/Bild/Python.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Omni/Bild/Python.nix')
-rw-r--r--Omni/Bild/Python.nix17
1 files changed, 12 insertions, 5 deletions
diff --git a/Omni/Bild/Python.nix b/Omni/Bild/Python.nix
index 6e4f390..23e9ecd 100644
--- a/Omni/Bild/Python.nix
+++ b/Omni/Bild/Python.nix
@@ -1,17 +1,24 @@
_self: super: {
- python3 = super.python3.override {
+ python312 = super.python312.override {
packageOverrides = _pyself: pysuper:
- with pysuper.pkgs.python3Packages;
+ with pysuper.pkgs.python312Packages;
let dontCheck = p: p.overridePythonAttrs (_: { doCheck = false; });
in {
interegular = callPackage ./Deps/interegular.nix { };
- llm-ollama = callPackage ./Deps/llm-ollama.nix { };
- llm-sentence-transformers =
- callPackage ./Deps/llm-sentence-transformers.nix { };
+ ludic = callPackage ./Deps/ludic.nix { };
mypy = dontCheck pysuper.mypy;
outlines = callPackage ./Deps/outlines.nix { };
perscache = callPackage ./Deps/perscache.nix { };
tokenizers = dontCheck pysuper.tokenizers;
};
};
+
+ python311 = super.python311.override {
+ packageOverrides = _pyself: pysuper:
+ with pysuper.pkgs.python311Packages; {
+ llm-ollama = callPackage ./Deps/llm-ollama.nix { };
+ llm-sentence-transformers =
+ callPackage ./Deps/llm-sentence-transformers.nix { };
+ };
+ };
}