summaryrefslogtreecommitdiff
path: root/Omni/Os/Boot.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Omni/Os/Boot.nix')
-rw-r--r--Omni/Os/Boot.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/Omni/Os/Boot.nix b/Omni/Os/Boot.nix
new file mode 100644
index 0000000..c789d89
--- /dev/null
+++ b/Omni/Os/Boot.nix
@@ -0,0 +1,14 @@
+{ bild }:
+/* This target creates a qcow2 image of a barebones NixOS VM which should be used
+ to bootstrap a deployment target.
+
+ The workflow is like this:
+
+ - bild this, you get a qcow2 image
+ - go to https://cloud.digitalocean.com/images/custom_images
+ - upload the image
+ - start a new droplet with this image
+ - once fully provisioned and accessible via ssh, the new droplet can be a deploy
+ target for any other namespace
+*/
+bild.droplet { imports = [ ./Base.nix ../Users.nix ]; }