summaryrefslogtreecommitdiff
path: root/Run/Que/Server.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Run/Que/Server.nix')
-rw-r--r--Run/Que/Server.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/Run/Que/Server.nix b/Run/Que/Server.nix
new file mode 100644
index 0000000..272ea6e
--- /dev/null
+++ b/Run/Que/Server.nix
@@ -0,0 +1,45 @@
+{ options
+, lib
+, config
+, pkgs
+, modulesPath
+}:
+
+let
+ cfg = config.services.que-server;
+in
+{
+ options.services.que-server = {
+ enable = lib.mkEnableOption "Enable the que-server service";
+ port = lib.mkOption {
+ type = lib.types.int;
+ default = 3000;
+ description = ''
+ The port on which que-server will listen for
+ incoming HTTP traffic.
+ '';
+ };
+ package = lib.mkOption {
+ type = lib.types.package;
+ description = "que-server package to use";
+ };
+ };
+ config = lib.mkIf cfg.enable {
+ systemd.services.que-server = {
+ path = [ cfg.package ];
+ wantedBy = [ "multi-user.target" ];
+ script = ''
+ ${cfg.package}/bin/que-server -p ${toString cfg.port}
+ '';
+ description = ''
+ Que server
+ '';
+ serviceConfig = {
+ KillSignal = "INT";
+ Type = "simple";
+ Restart = "on-abort";
+ RestartSec = "1";
+ };
+ };
+ };
+}