summaryrefslogtreecommitdiff
path: root/Run/Que/service.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Run/Que/service.nix')
-rw-r--r--Run/Que/service.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/Run/Que/service.nix b/Run/Que/service.nix
index 1d82bd6..aa68657 100644
--- a/Run/Que/service.nix
+++ b/Run/Que/service.nix
@@ -61,7 +61,8 @@ in
locations."/" = {
proxyPass = "http://localhost:${toString cfg.port}";
extraConfig = ''
- # forward the headers so the `guardIP` function works properly
+ proxy_set_header X-Real-IP $realip_remote_addr;
+ proxy_set_header X-Forwarded-Host $remote_addr;
proxy_pass_request_headers on;
'';
};