summaryrefslogtreecommitdiff
path: root/com/simatime/users.nix
diff options
context:
space:
mode:
Diffstat (limited to 'com/simatime/users.nix')
-rw-r--r--com/simatime/users.nix33
1 files changed, 0 insertions, 33 deletions
diff --git a/com/simatime/users.nix b/com/simatime/users.nix
deleted file mode 100644
index daac9d6..0000000
--- a/com/simatime/users.nix
+++ /dev/null
@@ -1,33 +0,0 @@
-{ ... }:
-
-let
- key = f: builtins.readFile (./keys/. + ("/" + f));
-in
-{
- users = {
- users = {
- # bots
- deploy = {
- isNormalUser = true;
- home = "/home/deploy";
- openssh.authorizedKeys.keys = [ (key "deploy.pub") ];
- extraGroups = [ "wheel" ];
- };
-
- # humans
- root.openssh.authorizedKeys.keys = [ (key "ben.pub") ];
- ben = {
- isNormalUser = true;
- home = "/home/ben";
- openssh.authorizedKeys.keys = [ (key "ben.pub") ];
- extraGroups = [ "wheel" "networkmanager" "docker" ];
- };
- nick = {
- isNormalUser = true;
- home = "/home/nick";
- openssh.authorizedKeys.keys = [ (key "nick.pub") ];
- extraGroups = [ "docker" ];
- };
- };
- };
-}