summaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix34
1 files changed, 7 insertions, 27 deletions
diff --git a/configuration.nix b/configuration.nix
index 1828d22..775bc99 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -1,5 +1,8 @@
{ ... }:
+let
+ bensIp = "68.107.97.20";
+in
{
nixpkgs.config.packageOverrides = pkgs: {
ibb = import ./ibb/default.nix {};
@@ -18,33 +21,10 @@
recommendedProxySettings = true;
recommendedTlsSettings = true;
virtualHosts = {
- "simatime.com" = {
- #forceSSL = true;
- #enableACME = true;
- locations = {
- "/" = {
- proxyPass = "http://68.107.97.20:8000";
- };
- };
- };
- "dev.simatime.com" = {
- #forceSSL = true;
- #enableACME = true;
- locations = {
- "/" = {
- proxyPass = "http://68.107.97.20:3000";
- };
- };
- };
- "hero.simatime.com" = {
- #forceSSL = true;
- #enableACME = true;
- locations = {
- "/" = {
- proxyPass = "http://68.107.97.20:3001";
- };
- };
- };
+ "simatime.com".locations."/".proxyPass = "http://${bensIp}:8000";
+ "dev.simatime.com".locations."/".proxyPass = "http://${bensIp}:3000";
+ "hero.simatime.com".locations."/".proxyPass = "http://${bensIp}:3001";
+ "tv.simatime.com".locations."/".proxyPass = "http://${bensIp}:8096"; # emby runs on port 8096
"influencedbybooks.com" = {
forceSSL = true;
enableACME = true;