summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix131
1 files changed, 65 insertions, 66 deletions
diff --git a/default.nix b/default.nix
index f60a2a1..54db612 100644
--- a/default.nix
+++ b/default.nix
@@ -11,8 +11,8 @@ let
url = "https://gitlab.com/simple-nixos-mailserver/nixos-mailserver/-/archive/${ver}/nixos-mailserver-${ver}.tar.gz";
sha256 = "0lpz08qviccvpfws2nm83n7m2r8add2wvfg9bljx9yxx8107r919";
};
-in {
- Com.Simatime = buildOS {
+in rec {
+ Com.Simatime.cloud = buildOS {
enableVpn = true;
ipAddress = "159.89.128.69";
vpnRsaPrivateKeyFile = "/etc/tinc/rsa_key.priv";
@@ -33,34 +33,36 @@ in {
withUtempter = true;
};
};
- } // {
- dev = buildOS {
- enableVpn = true;
- ipAddress = "69.181.254.154";
- vpnConnectTo = "com.simatime";
- vpnRsaPrivateKeyFile = "/etc/tinc/rsa_key.priv";
- vpnEd25519PrivateKeyFile = "/etc/tinc/ed25519_key.priv";
- configuration = {
- imports = [
- ./Com/Simatime/packages.nix
- ./Com/Simatime/dev/hardware.nix
- ./Com/Simatime/dev/configuration.nix
- ];
- };
+ };
+ Com.Simatime.dev = buildOS {
+ enableVpn = true;
+ ipAddress = "69.181.254.154";
+ vpnConnectTo = "com.simatime";
+ vpnRsaPrivateKeyFile = "/etc/tinc/rsa_key.priv";
+ vpnEd25519PrivateKeyFile = "/etc/tinc/ed25519_key.priv";
+ configuration = {
+ imports = [
+ ./Com/Simatime/packages.nix
+ ./Com/Simatime/dev/hardware.nix
+ ./Com/Simatime/dev/configuration.nix
+ ];
};
- Serval = buildOS {
- configuration = {
- imports = [
- ./Com/Simatime/packages.nix
- ./Com/RunServal/hardware.nix
- ./Com/RunServal/networking.nix
- ];
- networking.hostName = "serval.simatime.com";
- boot.enableContainers = true;
- };
+ };
+ Com.Simatime.Serval = buildOS {
+ deps = { que-server = Run.Que; };
+ configuration = {
+ imports = [
+ ./Com/Simatime/packages.nix
+ ./Com/Simatime/Serval/hardware.nix
+ ./Com/Simatime/Serval/networking.nix
+ ./Run/Que/service.nix
+ ./Com/Simatime/Serval/configuration.nix
+ ];
+ networking.hostName = "serval.simatime.com";
+ boot.enableContainers = true;
};
};
- Com.InfluencedByBooks = buildOS {
+ Com.InfluencedByBooks.os = buildOS {
configuration = {
imports = [
./Com/InfluencedByBooks/service.nix
@@ -70,43 +72,42 @@ in {
boot.isContainer = true;
networking.useDHCP = false;
};
- } // {
- Server = buildGhc {
- name = "Com.InfluencedByBooks.Server";
- nick = "ibb";
- deps = [
- "clay"
- "miso"
- "protolude"
- "servant"
- "text"
- "MonadRandom"
- "acid-state"
- "blaze-html"
- "blaze-markup"
- "bytestring"
- "ixset"
- "random"
- "safecopy"
- "scotty"
- "servant-server"
- "text"
- ];
- };
- Client = buildGhcjs {
- name = "Com.InfluencedByBooks.Client";
- nick = "ibb";
- deps = [
- "clay"
- "miso"
- "protolude"
- "servant"
- "text"
- "aeson"
- "containers"
- "ghcjs-base"
- ];
- };
+ };
+ Com.InfluencedByBooks.Server = buildGhc {
+ name = "Com.InfluencedByBooks.Server";
+ nick = "ibb";
+ deps = [
+ "clay"
+ "miso"
+ "protolude"
+ "servant"
+ "text"
+ "MonadRandom"
+ "acid-state"
+ "blaze-html"
+ "blaze-markup"
+ "bytestring"
+ "ixset"
+ "random"
+ "safecopy"
+ "scotty"
+ "servant-server"
+ "text"
+ ];
+ };
+ Com.InfluencedByBooks.Client = buildGhcjs {
+ name = "Com.InfluencedByBooks.Client";
+ nick = "ibb";
+ deps = [
+ "clay"
+ "miso"
+ "protolude"
+ "servant"
+ "text"
+ "aeson"
+ "containers"
+ "ghcjs-base"
+ ];
};
Com.MusicMeetsComics = {
Server = buildGhc {
@@ -175,6 +176,4 @@ in {
"unordered-containers"
];
};
- # fallthrough to nixpkgs
- nixpkgs = nixpkgs;
}