summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix118
1 files changed, 8 insertions, 110 deletions
diff --git a/default.nix b/default.nix
index 5199252..41a1f0b 100644
--- a/default.nix
+++ b/default.nix
@@ -70,114 +70,12 @@ in rec {
boot.enableContainers = true;
};
};
- Com.InfluencedByBooks.Server = buildGhc {
- name = "Com.InfluencedByBooks.Server";
- nick = "ibb";
- deps = [
- "clay"
- "miso"
- "protolude"
- "servant"
- "text"
- "MonadRandom"
- "acid-state"
- "blaze-html"
- "blaze-markup"
- "bytestring"
- "ixset"
- "random"
- "safecopy"
- "scotty"
- "servant-server"
- "text"
- ];
- };
- Com.InfluencedByBooks.Client = buildGhcjs {
- name = "Com.InfluencedByBooks.Client";
- nick = "ibb";
- deps = [
- "clay"
- "miso"
- "protolude"
- "servant"
- "text"
- "aeson"
- "containers"
- "ghcjs-base"
- ];
- };
- Com.MusicMeetsComics = {
- Server = buildGhc {
- name = "Com.MusicMeetsComics.Server";
- nick = "mmc";
- deps = [
- "aeson"
- "clay"
- "containers"
- "miso"
- "protolude"
- "servant"
- "split"
- "string-quote"
- "text"
- "dhall"
- "ekg"
- "fast-logger"
- "http-types"
- "katip"
- "lucid"
- "monad-logger"
- "monad-metrics"
- "mtl"
- "network-uri"
- "safe"
- "servant-lucid"
- "servant-server"
- "split"
- "wai"
- "wai-app-static"
- "wai-extra"
- "wai-middleware-metrics"
- "warp"
- ];
- };
- Client = buildGhcjs {
- name = "Com.MusicMeetsComics.Client";
- nick = "mmc";
- deps = [
- "aeson"
- "clay"
- "containers"
- "miso"
- "protolude"
- "servant"
- "split"
- "string-quote"
- "text"
- "ghcjs-base"
- ];
- };
- };
- Run.Que.Server = buildGhc {
- name = "Run.Que.Server";
- nick = "que-server";
- deps = [
- "async"
- "protolude"
- "scotty"
- "stm"
- "unagi-chan"
- "unordered-containers"
- ];
- };
- Run.Que.Website = buildGhc {
- name = "Run.Que.Website";
- nick = "que-website";
- deps = [
- "async"
- "process"
- "protolude"
- "req"
- ];
- };
+ # Haskell targets
+ #
+ Com.InfluencedByBooks.Server = buildGhc Com/InfluencedByBooks/Server.hs;
+ Com.InfluencedByBooks.Client = buildGhcjs Com/InfluencedByBooks/Client.hs;
+ Com.MusicMeetsComics.Server = buildGhc Com/MusicMeetsComics/Server.hs;
+ Com.MusicMeetsComics.Client = buildGhcjs Com/MusicMeetsComics/Client.hs;
+ Run.Que.Server = buildGhc ./Run/Que/Server.hs;
+ Run.Que.Website = buildGhc ./Run/Que/Website.hs;
}