summaryrefslogtreecommitdiff
path: root/depo/hidor-kahih/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'depo/hidor-kahih/default.nix')
-rw-r--r--depo/hidor-kahih/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/depo/hidor-kahih/default.nix b/depo/hidor-kahih/default.nix
new file mode 100644
index 0000000..606ce29
--- /dev/null
+++ b/depo/hidor-kahih/default.nix
@@ -0,0 +1,25 @@
+/*
+
+hidor-kahih - main development/build server
+
+*/
+
+let
+ nixpkgs = builtins.fetchTarball (import ../../pack/nixpkgs.nix);
+in
+import "${nixpkgs}/nixos" {
+ system = "x86_64-linux";
+ configuration = {
+ nixpkgs.overlays = [
+ (import ../../pack/overlay.nix)
+ ];
+
+ imports =
+ [ ./hardware.nix
+ ../users.nix
+ ./configuration.nix
+ ];
+
+ users.users.root.openssh.authorizedKeys.keys = [(builtins.readFile ../../keys/ben.pub)];
+ };
+}