summaryrefslogtreecommitdiff
path: root/ibb/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ibb/default.nix')
-rw-r--r--ibb/default.nix42
1 files changed, 21 insertions, 21 deletions
diff --git a/ibb/default.nix b/ibb/default.nix
index 4384001..1d6a065 100644
--- a/ibb/default.nix
+++ b/ibb/default.nix
@@ -1,23 +1,23 @@
-{ stdenv
-, mkDerivation
-, base
+{ compiler ? "ghc843"
+, doHaddock ? false
+, doBenchmark ? false
+, doCheck ? true
+, withHoogle ? false
+, pkgs ? import (fetchGit (import ../pkgs.nix)) {}
}:
-mkDerivation {
- pname = "ibb";
- version = "0";
- src = ./.;
- isExecutable = true;
- libraryHaskellDepends = [
- base
- ];
- executableHaskellDepends = [
- base
- ];
- testHaskellDepends = [
- base
- ];
- homepage = "https://git.sr.ht/~ben/biz";
- description = "biz";
- license = stdenv.lib.licenses.bsd3;
-}
+with pkgs;
+
+haskell.packages.${compiler}.developPackage {
+ root = ./.;
+ overrides = with haskell.lib; self: super: {
+ ghc =
+ if withHoogle
+ then super.ghc // {withPackages = super.ghc.withHoogle;}
+ else super.ghc;
+ ghcWithPackages =
+ if withHoogle
+ then self.ghc.withPackages
+ else super.ghcWithPackages;
+ };
+} \ No newline at end of file