summaryrefslogtreecommitdiff
path: root/nix/build.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/build.nix')
-rw-r--r--nix/build.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nix/build.nix b/nix/build.nix
index 6f979d7..dd16df6 100644
--- a/nix/build.nix
+++ b/nix/build.nix
@@ -17,7 +17,7 @@ let
subset = a: b: builtins.all
(x: builtins.elem x b) a;
- allDeps = import ./deps.nix;
+ allDeps = import ./haskell-deps.nix;
# gather data needed for compiling by analyzing the main module
analyze = main: rec {
@@ -42,7 +42,7 @@ let
if (subset deps allDeps)
then depsToPackageSet hp deps
else throw ''
- missing from deps.nix:
+ missing from nix/haskell-deps.nix:
${toString (lib.lists.subtractLists allDeps deps)}
''));