summaryrefslogtreecommitdiff
path: root/pack/ibb.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pack/ibb.nix')
-rw-r--r--pack/ibb.nix8
1 files changed, 3 insertions, 5 deletions
diff --git a/pack/ibb.nix b/pack/ibb.nix
index feb99f9..6bf84d8 100644
--- a/pack/ibb.nix
+++ b/pack/ibb.nix
@@ -5,12 +5,14 @@ let
blaze-html
blaze-markup
bytestring
+ hinotify
MonadRandom
random
scotty
shakespeare
text
]);
+ make = ../chip/make;
entrypoint = "Ibb";
in
stdenv.mkDerivation rec {
@@ -21,11 +23,7 @@ stdenv.mkDerivation rec {
ghc
];
strictDeps = true;
- buildPhase = ''
- ${ghc}/bin/ghc -iapex -ilore \
- -main-is ${entrypoint} --make apex/${entrypoint}.hs \
- -o bild/${name}
- '';
+ buildPhase = "${ghc}/bin/runhaskell ${make} ibb";
installPhase = ''
mkdir -p $out/bin
cp bild/${name} $out/bin/${name}