summaryrefslogtreecommitdiff
path: root/pack/ibb.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pack/ibb.nix')
-rw-r--r--pack/ibb.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/pack/ibb.nix b/pack/ibb.nix
index 4224974..bd72310 100644
--- a/pack/ibb.nix
+++ b/pack/ibb.nix
@@ -10,6 +10,7 @@ let
shakespeare
text
]);
+ entrypoint = "Ibb";
in
stdenv.mkDerivation rec {
name = "ibb";
@@ -20,7 +21,9 @@ stdenv.mkDerivation rec {
];
strictDeps = true;
buildPhase = ''
- ${ghc}/bin/ghc -iapex -ilore -main-is Ibb --make apex/Ibb.hs -o bild/${name}
+ ${ghc}/bin/ghc -iapex -ilore \
+ -main-is ${entrypoint} --make apex/${entrypoint}.hs \
+ -o bild/${name}
'';
installPhase = ''
mkdir -p $out/bin