summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml33
1 files changed, 30 insertions, 3 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 7f7d0d3..dbb1de1 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,33 @@
-[tool.black]
-line-length = 80
-
[tool.mypy]
strict = true
implicit_reexport = true
+
+[tool.ruff]
+exclude = ["_", ".git"]
+line-length = 80
+indent-width = 4
+target-version = "py310"
+
+[tool.ruff.format]
+preview = true
+quote-style = "double"
+indent-style = "space"
+skip-magic-trailing-comma = false
+line-ending = "auto"
+
+[tool.ruff.lint]
+preview = true
+select = ["ALL"]
+fixable = ["ALL"]
+ignore = [
+ "ANN401", # any-type, we allow typing.Any, although we shouldn't
+ "CPY001", # missing-copyright-notice
+ "D203", # no-blank-line-before-class
+ "D212", # multi-line-summary-first-line
+ "E203", # whitespace-before-punctuation, doesn't work with ruff format
+ "INP001", # implicit-namespace-package
+ "N999", # invalid-module-name
+ "S310", # suspicious-url-open-usage, doesn't work in 0.1.5
+ "S603", # subprocess-without-shell-equals-true, false positives
+ "S607", # start-process-with-partial-path
+]