summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 025e630..b15c40c 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -25,7 +25,9 @@ ignore = [
"CPY001", # missing-copyright-notice
"D203", # no-blank-line-before-class
"D212", # multi-line-summary-first-line
+ "DOC201", # docstring-missing-returns
"E203", # whitespace-before-punctuation, doesn't work with ruff format
+ "EXE001", # shebang-not-executable, remove this when run.sh is working
"INP001", # implicit-namespace-package
"N999", # invalid-module-name
"PLR0402", # manual-from-import, prefer imports like Haskell
@@ -42,3 +44,5 @@ ignore = [
no-sections = true
force-single-line = true
+[tool.ruff.lint.pydocstyle]
+convention = "pep257"