summaryrefslogtreecommitdiff
path: root/email.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-02-18 11:57:33 -0800
committerBen Sima <ben@bsima.me>2019-02-18 11:57:33 -0800
commit1c8649582f8f7b65592da12badffb1b509288f2b (patch)
treec751a12247581b7134ca7fce3b6ece3210fea0af /email.nix
parent6469b5dd163b9b7784a81d42696491f0859d0ea3 (diff)
Add UE mails
Diffstat (limited to 'email.nix')
-rw-r--r--email.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/email.nix b/email.nix
index f085943..9efaa00 100644
--- a/email.nix
+++ b/email.nix
@@ -33,6 +33,7 @@ in
msmtp.enable = true;
passwordCommand = "pass bnet/helium/mail/ben";
};
+
"ben@simatime.com" = {
realName = "Ben Sima";
address = "ben@simatime.com";
@@ -54,6 +55,39 @@ in
passwordCommand = "pass simatime/mail/ben";
msmtp.enable = true;
};
+
+ "bsima@undergroundelephant.com" = {
+ flavor = "gmail.com";
+ realName = "Ben Sima";
+ address = "bsima@undergroundelephant.com";
+ userName = "bsima@undergroundelephant.com";
+ mbsync = {
+ enable = true;
+ create = "both";
+ expunge = "none";
+ };
+ notmuch.enable = true;
+ msmtp.enable = true;
+ passwordCommand = "pass work/ue/gmail";
+ smtp.tls.useStartTls = true;
+ };
+
+ # Auth is blocked by Google policies
+ #"ben.sima@heroprojects.io" = {
+ # flavor = "gmail.com";
+ # realName = "Ben Sima";
+ # address = "ben.sima@heroprojects.io";
+ # userName = "ben.sima@heroprojects.io";
+ # mbsync = {
+ # enable = true;
+ # create = "both";
+ # expunge = "none";
+ # };
+ # notmuch.enable = true;
+ # msmtp.enable = true;
+ # passwordCommand = "pass work/hero/gmail";
+ # smtp.tls.useStartTls = true;
+ #};
};
};
};