summaryrefslogtreecommitdiff
path: root/lib/urxvt.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-08-03 11:46:05 -0400
committerBen Sima <ben@bsima.me>2024-08-14 13:57:56 -0400
commit994f29c31d9329f627c5a588cdebe76606e4292f (patch)
treeccb642ab82f271f60ed8ca15ad36fcc293a932d4 /lib/urxvt.nix
parent2384b5314eb2fb961bd57d6fb6c5c78cab31dd1c (diff)
messing with xterm and font sizes
Diffstat (limited to 'lib/urxvt.nix')
-rw-r--r--lib/urxvt.nix12
1 files changed, 9 insertions, 3 deletions
diff --git a/lib/urxvt.nix b/lib/urxvt.nix
index 7fe2351..a25bc68 100644
--- a/lib/urxvt.nix
+++ b/lib/urxvt.nix
@@ -1,9 +1,15 @@
{ ... }:
let
- #inherit (import ./const.nix) fontSize;
- fontSize = 10;
+ inherit (import ./const.nix) fontSize;
+ #fontSize = 10;
+ #font = name: size: "xft:${name}:size=${toString size}:ant";
+
+ # why doesn't font size work right? It is always either too large or too
+ # small... what if I just don't set font size?
+ # ->
+ font = name: size: "xft:${name}:ant";
in {
- programs.urxvt = let font = name: size: "xft:${name}:size=${toString size}:ant"; in {
+ programs.urxvt = {
enable = true;
fonts = [
(font "Fira Code" fontSize)