summaryrefslogtreecommitdiff
path: root/lib/urxvt.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/urxvt.nix')
-rw-r--r--lib/urxvt.nix12
1 files changed, 9 insertions, 3 deletions
diff --git a/lib/urxvt.nix b/lib/urxvt.nix
index 7fe2351..a25bc68 100644
--- a/lib/urxvt.nix
+++ b/lib/urxvt.nix
@@ -1,9 +1,15 @@
{ ... }:
let
- #inherit (import ./const.nix) fontSize;
- fontSize = 10;
+ inherit (import ./const.nix) fontSize;
+ #fontSize = 10;
+ #font = name: size: "xft:${name}:size=${toString size}:ant";
+
+ # why doesn't font size work right? It is always either too large or too
+ # small... what if I just don't set font size?
+ # ->
+ font = name: size: "xft:${name}:ant";
in {
- programs.urxvt = let font = name: size: "xft:${name}:size=${toString size}:ant"; in {
+ programs.urxvt = {
enable = true;
fonts = [
(font "Fira Code" fontSize)