summaryrefslogtreecommitdiff
path: root/linux.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-04-08 11:36:11 -0700
committerBen Sima <ben@bsima.me>2019-04-08 11:36:11 -0700
commit9b9cd0d710703496b14506b3ea4cab896aff77d5 (patch)
tree6c8e484dd25f697bb19857ac169e93dafb65ad42 /linux.nix
parent9cd7398f09fcef9ed3574660146892d8bce4de44 (diff)
Set default theme
Diffstat (limited to 'linux.nix')
-rw-r--r--linux.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/linux.nix b/linux.nix
index 8247bba..f8318c8 100644
--- a/linux.nix
+++ b/linux.nix
@@ -2,7 +2,9 @@
let
solarized-xresources = ./xresources;
- theme = builtins.getEnv "XTHEME";
+ themeVar = builtins.getEnv "XTHEME";
+ defaultTheme = "light";
+ theme = if themeVar == "" then defaultTheme else themeVar;
colors = {
"dark" = {
background = "#292b2e";