summaryrefslogtreecommitdiff
path: root/linux.nix
diff options
context:
space:
mode:
Diffstat (limited to 'linux.nix')
-rw-r--r--linux.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/linux.nix b/linux.nix
index 8247bba..f8318c8 100644
--- a/linux.nix
+++ b/linux.nix
@@ -2,7 +2,9 @@
let
solarized-xresources = ./xresources;
- theme = builtins.getEnv "XTHEME";
+ themeVar = builtins.getEnv "XTHEME";
+ defaultTheme = "light";
+ theme = if themeVar == "" then defaultTheme else themeVar;
colors = {
"dark" = {
background = "#292b2e";